SPGE - Service Disruption Notification

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 12:27 EST

Monitoring

We are aware of an issue impacting services across S&P Global Energy. Our team is working quickly to resolve the issue.

We understand the inconvenience this may cause and appreciate your patience and understanding as we work to resolve the issue promptly. Our top priority is to restore full functionality and ensure the reliability of our services.
Posted Feb 18, 2026 - 12:25 EST
This incident affected: Upstream Solutions (Information Hub Direct Connect - IHDC).