Energy Documents - Document Download Service Disruption

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 18:12 EDT

Identified

Energy Documents and related services are currently experiencing an issue impacting document downloads. Users can access and search for documents; however, download functionality is unavailable. Our teams have identified the issue and are actively working to restore service as quickly as possible
Posted Jul 20, 2026 - 18:01 EDT
This incident affected: Upstream Solutions (Energy Data Services, Energy Docs, AccuLogs).