SPGE - Service Disruption Notification

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 23:21 EST

Update

We are continuing to investigate this issue.
Posted Feb 05, 2026 - 23:18 EST

Update

We are continuing to investigate this issue.
Posted Feb 05, 2026 - 04:50 EST

Investigating

We are experiencing service issue with Energy IHS Information Hub.
Our engineers are actively working to restore the services. We appreciate your patience.

We understand the inconvenience this may cause and appreciate your patience and understanding as we work to resolve the issue promptly.
If you require further assistance, please contact the Client Service team via support.energy@spglobal.com.
Posted Feb 05, 2026 - 03:59 EST
This incident affected: Upstream Solutions (Information Hub Direct Connect - IHDC).