Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 09:57 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2026 - 06:48 EDT

Identified

We have identified an issue affecting the ENOD service and are working to restore normal functionality. Our technology teams are actively working to restore the services. We appreciate your patience.

If you require further assistance, please contact the Client Service team via support.energy@spglobal.com
Posted Mar 09, 2026 - 06:48 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2026 - 01:00 EDT
This incident affected: Upstream Solutions (Enod).