Data Not Updating in Agribusines Intelligence App

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 15:27 EDT

Identified

We are currently investigating an issue impacting Agribusines Intelligence, where certain data updates are not appearing in client dashboards within Connect and Core platforms. Our technical teams have identified the source of the issue and are working to restore normal data processing.
Posted Aug 04, 2026 - 14:38 EDT
This incident affected: Delivery Platforms (S&P Global Energy Core, S&P Connect).