We are still working on the issue involving duplicate records in the SPGE LNG Global Analytics Outage data delivered through our Cloud Data Platforms (Snowflake and Databricks).
The issue affecting the Outage view / table has been fixed, while remediation efforts for the Waterborne and Tenders datasets are ongoing. The Waterborne dataset is expected to be released by tomorrow, and analysis on the Tenders dataset continues.
Further updates will be shared as they become available. If you require assistance, please contact the Client Service team via support.energy@spglobal.com.
Posted Mar 30, 2026 - 13:47 EDT
Update
We are continuing to investigate reports of potential duplicate records impacting SPGE LNG Global Analytics Outage data delivered through our Cloud Data Platforms, including Snowflake and Databricks.
The Order dataset has been resolved, while our technical teams remain actively engaged in addressing the Tenders and Waterborne datasets as a priority. The teams are targeting completion of this work and deployment to production by Monday, March 30th.
Further updates will be shared as they become available. If you require assistance, please contact the Client Service team via support.energy@spglobal.com.
Posted Mar 27, 2026 - 10:29 EDT
Identified
We are currently investigating reports of potential duplicate records impacting SPGE LNG Global Analytics Outage data delivered through our Cloud Data Platforms (Snowflake and Databricks).
Our technical teams are actively working to identify the root cause and resolve this as a priority. If you require further assistance, please contact the Client Service team via support.energy@spglobal.com.
Posted Mar 26, 2026 - 08:56 EDT
This incident affected: Cloud Data Platforms (Snowflake, Databricks Delta Sharing).