Data Availability Issues via Databricks

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 18:27 EDT

Investigating

We are currently investigating an issue affecting data availability through Databricks. Data remains available through alternative access methods, including API and Snowflake. Our teams are actively working to restore normal service and will provide updates as they become available.
Posted Jul 24, 2026 - 17:09 EDT
This incident affected: Cloud Data Platforms (Databricks Delta Sharing).