Agribusiness Data Not Updating in SPGE Core

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 15:46 EDT

Identified

We have identified the cause of the issue impacting agribusiness data updates and have implemented a fix. Validation is currently underway to confirm normal service operation. Further updates will be provided as they become available.
Posted Aug 20, 2026 - 10:31 EDT
This incident affected: Delivery Platforms (S&P Global Energy Core).