Energy Studio Impact Performance Degradation

Resolved

This incident has been resolved.
Posted Jul 11, 2026 - 00:49 EDT

Identified

Our teams have identified the cause of the dashboard performance degradation and are actively working to restore normal service. Users may continue to experience slower-than-normal dashboard loading times while remediation efforts are underway.
Posted Jul 10, 2026 - 13:54 EDT

Investigating

We are currently investigating an issue affecting Energy Studio Impact that is causing slower-than-normal dashboard loading times.
Posted Jul 10, 2026 - 11:23 EDT
This incident affected: Content Platforms (Energy Studio Impact).