Service Disruption Notification - AWS Outage

Resolved

This incident has been resolved.
Posted May 09, 2026 - 02:27 EDT

Update

The Energy Division (SPGE) teams continue to actively monitor all services. While there is currently no disruption to services, teams remain on heightened alert as a precautionary measure.
Posted May 08, 2026 - 10:08 EDT

Update

AWS has reported early signs of recovery in the affected availability zone. AWS continues working towards restoring bringing the remaining impacted infrastructure back online in a controlled manner.
Posted May 08, 2026 - 02:42 EDT

Update

One availability zone in the AWS US East region is currently experiencing issues. No impact to Energy Division (SPGE) Services.
Posted May 08, 2026 - 02:40 EDT

Monitoring

We are currently aware of an ongoing issue affecting Amazon Web Services (AWS). Initial analysis indicates there is no immediate impact to SPG Energy services at this time, and we are continuing to closely monitor the situation.
Posted May 08, 2026 - 02:39 EDT

Investigating

An AWS service disruption is affecting a single availability zone (use1-az4) in the US-EAST-1 region, which has caused some server connectivity degradation. Our teams are engaged and actively investigating the issue.
Posted May 08, 2026 - 01:54 EDT
This incident affected: Cloud Data Platforms (Amazon Web Services (AWS) Data Exchange, Third-Party Platforms).