Intermittent Customer Access Issue to Enerdeq

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 17:51 EDT

Investigating

We are investigating intermittent access issues affecting some users of Enerdeq. Customers may experience occasional errors or timeouts when accessing the application. Our teams are actively working to identify the cause and restore stable access.
Posted Sep 11, 2026 - 17:34 EDT
This incident affected: Upstream Solutions (Enerdeq).