SPGE Energy Studio - Impact Access Issue

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 20:52 EDT

Identified

Teams have identified the cause of the issue and are actively implementing corrective actions to restore access to the Energy Studio - Impact application. Work is progressing, and further updates will be provided as they become available.
Posted Jul 21, 2026 - 16:40 EDT

Investigating

We are investigating an issue impacting SPGE Energy Studio - Impact. Users may be unable to access or launch the application. Our teams are actively working to identify the root cause and restore service. Further updates will be provided as available.
Posted Jul 21, 2026 - 16:00 EDT
This incident affected: Content Platforms (Energy Studio Impact).