Energy Documents - Document Download Service Disruption

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 16:51 EDT

Identified

Energy Documents and related services are currently experiencing an issue impacting document downloads. Users can access and search for documents; however, download functionality is unavailable. Our teams have identified the issue and are actively working to restore service as quickly as possible. We apologize for the inconvenience and will provide further updates as they become available.
Posted Jul 20, 2026 - 16:49 EDT
This incident affected: Upstream Solutions (Energy Data Services).