Energy Studio Impact Performance Degradation

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 11:53 EDT

Investigating

We are currently investigating an issue affecting Energy Studio Impact that is causing slower-than-normal dashboard loading times.
Posted Jul 14, 2026 - 01:32 EDT
This incident affected: Content Platforms (Energy Studio Impact).