SPGE sFTP - Service Disruption Notification

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 01:12 EDT

Investigating

We are experiencing service issues with S&P Global Energy sFTP Platform. S&P Global engineers are actively working to restore the services. We appreciate your patience.

If you require further assistance, please contact the Client Service team via support.energy@spglobal.com.
Posted Mar 26, 2026 - 01:11 EDT
This incident affected: Delivery Platforms (S&P Global Energy FTP Delivery).