Environmental Registry (RAAS) Performance Degradation

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 13:26 EDT

Investigating

We are aware of an issue causing slower-than-normal performance within the Environmental Registry platform. Our teams are actively working to resolve the issue and restore normal service. We apologize for any inconvenience.
Posted Sep 14, 2026 - 13:09 EDT
This incident affected: Registry Services (Registry as a Service).