Access Issues Across SPGE Platforms

Resolved

This incident has been resolved.
Posted Aug 28, 2026 - 09:39 EDT

Identified

We are currently experiencing an issue affecting multiple platforms, which may impact access to certain services and products. Our technical teams have identified the root cause and are actively working to restore normal service as quickly as possible. We appreciate your patience and understanding while we resolve this matter.
Posted Aug 28, 2026 - 09:37 EDT
This incident affected: Delivery Platforms (S&P Global Energy Core).