S&P Global Energy Core

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 16:04 EDT

Identified

We are currently experiencing an issue affecting refreshable Excel files from SPGE Core, where updates are not being reflected, impacting access to the latest pricing and data. Our SPGE Core teams are actively investigating this issue.
In the interim, as a workaround, we recommend re-downloading the Excel files from SPGE Core to access the most up-to-date data.
Posted Jun 16, 2026 - 21:06 EDT
This incident affected: Delivery Platforms (S&P Global Energy Core).