Well Data Service Access Issue

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 18:59 EDT

Investigating

We are investigating an issue impacting access to Well Data services through the Energy Division (SPGE) application. Clients may experience difficulties accessing the service. Our teams are actively working to restore normal functionality and will provide further updates as they become available.
Posted Jul 23, 2026 - 18:46 EDT