Energy Core Dataset Download Degradation in China

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 18:21 EDT

Investigating

Some clients in China may be experiencing issues downloading datasets from the Energy Core platform. We are actively investigating the issue and will provide updates as more information becomes available
Posted Sep 14, 2026 - 11:33 EDT
This incident affected: Delivery Platforms (S&P Global Energy Core).