EDIN Map Services - Valid Contract Block Layer Data Unavailable

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 01:12 EDT

Investigating

We are investigating an issue affecting the Valid Contract Block layer within EDIN Map Services on the Energy Portal. Users may be unable to view data for this specific layer. All other map layers and application functionality remain operational. Our teams are actively working to identify the root cause and restore full service.
Posted Aug 12, 2026 - 18:35 EDT